Asrock H110 Pro BTC+

Hi. Stupid question

I finally got my H110 to post after replacing the Cpu. Now, the damn thing keeps freezing. I flashed the BIOS to see if that would help as well as reset the cmos and removed the battery. No luck. I can startup, start downloading the drivers etc and… STUCK. Anyone had similar issues?

If I try on board graphics, I can only see the BIOS, Windows starts and I get a blank screen after that, so I’m forced to use u GPU for video.

Oh, I have also ramped the ram up to 2100mhz, that’s the max on the G4400 Cpu.

I’m running 3 x EVGA GTX 1060 6gb (Mining cards no output) and 2 x Saphire Rx570 8gb.

Any ideas?

have you tried something like simple miner smos?

Also you’re going to have a really bad time running an nvidia+AMD gpu mining rig, its not worth the hassle.


I’ll take a look.
Really didn’t want to have to split the cards. But guess I’ll need to. Means I need another PSU.
Thanks for the heads up

I had the issue with the onboard graphics on my first H110 board.
-If you already have windows installed, go to the device manager and de-install the drivers from every GPU
-then restart and go into the BIOS, enable Onboard Graphics and set the primary graphics adapter to onboard (2 separate settings)
-restart windows and install the Intel graphics driver
-restart and install all the other drivers
now you should be able to use the onboard graphics
If that doesn’t work you may have to reinstall windows, first with the onboard alone. After the install you turn it off and hook up all the other GPUs
2. check your RAM and make sure the RAM settings in the BIOS match the rating on the RAM
the rating on the RAM is the max. you can use, if that is unstable, you can use pretty much any speed below that rating
3. not sure about the mixing of AMD and Nvidia, but if you can install the drivers and have a stable system, you can run two instances of your mining software, one for the AMD cards and one for the Nvidia cards
never done this on the H110 though, but on several other boards
I would make sure though, that they are in order (all AMD on PCIE-1, PCIE-2… and all Nvidia cards on PCIE1_1, PCIE2_1 and so on)

1 Like

When using external GPU the windows resolution might be set higher than the onboard graphics card can perform at.

Say your external GPU is set to 2k … 1440 or higher. The onboard graphics controller may not be able to do that resolution and once windows boots then switches resolution …blank screen.

Just a thought, but yes the BIOS settings mentioned above on your 1st drive to enable … and the selection of onboard graphics or PCIE are important.

I would go with what Vosk stated, SMOS so easy to use…


After some reading, if I understand correctly.

Download image, reboot using the thumb drive over hdd and off you go? All setups are done cloud-based once pc is running. So it would replace windows basically. Or did I miss something.

Thanks for the feedback


Correct, its simple, easy to use and no need for windows OS its well worth the cheap monthly fee. Sounds like you got the right way to set it up i know vosk has a bunch of old youtube videos on setting it up and they are more or less done the same way.

Simple Miner smos. I cannot get my rig to mine. I really don’t get it. 5 gpus, only reads 3. Then I get this

your mining address may be missing a “space” or have too many spaces in the configuration file.
That’s ONE problem … the address may be correct but not typed in the correct space.

Two, you may have a problem with your risers/cables. All cards need to be powered, all risers need to be powered.

Work on those issues first. Post your online configuration file if you want a more in depth discussion of Problem #1

This is my miner string

Its to run on claymore 15

-wd 1 -r 1 -epool pool:port - 0xdbe5074fcec481421675676e48d67c2b97e1213c Walsh1 -esm 0 -epsw x -allpools 1 -asm 1 -mport

all risers have power. Just added additional sata power to the board h110 btc pro

@Scoobylaw Your error messages are a result of you having not properly defined your config file. All the variables start with a command which comprises a dash and a word (eg -epools) followed by a space and then your input to the config file. So you have to actually define a pool where your config file shows “pool:port”. Whatever pool you are trying to mine to will have a webpage and list the pool address and port in a configuration that looks something like this “stratum+tcp://” (that’s my nicehash pool and port address). Find yours and put it in your config file where it says pool:port.

Next you have a dash all by itself which is not a recognised command but seems as though it might be trying to point to your wallet. It probably should be something like “-wal 0xdbe5074fcec481421675676e48d67c2b97e1213c.Walsh1” Note that your Eth wallet address and your rig name are usually separated by a fullstop not a space.

Try fixing those errors and see how you go.

Hi @Badfish. Yeah, fixed the configuration file, but miner kept bombing and dropping cards. Swapped the psu and changed the mobo. Running like a boss now

1 Like

Hi all. Is this considered good? I feel like the 580s are pulling too much

Your miner string looks like one built online where the -epool:port is previously defined as in this example:
-epool [] -ewal (which is missing) is -ewal 0xdbe5074fcec481421675676e48d67c2b97e1213c and also missing the command in front of Walsh1, -eworker Walsh1. the rest looks correct. It seems you don’t need, and didn’t, specify the algorithm so that is correct as well.

I’ll list an SSL and Stratum=tcp batch file I use and place your address and worker in it if that will help.

Normal batch file to mine on ethermine: The setx variables help with AMD cards:

EthDcrMiner64.exe -epool -ewal 0xdbe5074fcec481421675676e48d67c2b97e1213c -eworker Walsh1 -ethi 12 -mode 1 -r 0 -dbg -1 -mport -3333 -etha 0 -retrydelay 10 -ftime 55 -tt 45 -ttli 77 -tstop 89 -fanmin 50 -asm 0 -allpools 1

Here is a batch file contents to mine with SSL so no man in the middle can hijack your ETH:

EthDcrMiner64.exe -epool ssl:// -ewal 0xdbe5074fcec481421675676e48d67c2b97e1213c -eworker Walsh1 -ethi 13 -mode 1 -etha 0 -r 0 -dbg -1 -mport -3333

You can include the setx variables if you want for AMD cards.

Finally, a standard batch file for 2Miners Pool:


EthDcrMiner64.exe -epool -ewal 0xdbe5074fcec481421675676e48d67c2b97e1213c -eworker Walsh1 -epsw x -ethi 12 -mode 1 -r 0 -dbg -1 -mport -3333 -etha 0 -retrydelay 10 -ftime 55 -tt 45 -ttli 77 -tstop 89 -fanmin 50 -asm 0 -allpools 1

Those batch files should get you going on ethermine or 2Miners pools. May help with finding video cards but not likely. I think that is a different issue.

Good Luck

Thanks for the info.

I tried those strings, but my cards dropped to 14mhs, so I opted out.

The guy I bought the cards from shared a bios mod and now all cards are30mhs and 87w. I’ll take it.

Thanks again

1 Like