B250 Mining Expert Board - no video output

Okay… So I purchased two B250 MotherBoards for two rigs

Here is the lineup:

i5-7400 CPU - Verified it is compatible with ASUS via their FAQ.

Memory is DDR4 2400 Hz

I have connected the PS to MB connector “A”

CPU power is connected on the MB

Hooked up a SATA SSD.

Upon power-up, the CPU cooler fan starts up and then nothing. No BIOS no post. Just a blank screen and the monitor shifts to another display due to no signal.

Although this CPU has onboard graphics, I tried out a GPU in the PCIe X16 slot. Same result.

So I either have two bad motherboards, new from ASUS, or I am missing something?

Thanks.

I had the exact same issue 7 - 8 months ago. I bought 2x ASUS B250 but an 8th gen i7. First I thought it’s the BIOS update issue (you need a 7th gen CPU to do the update for the 8th gen Intel). Went out and bought a cheap 7th gen i3, but didn’t work either. I then tried the CPU’s in another motherboard and both didn’t run. So I RMA"d the CPU’s. It took 4 weeks for the new CPU’s to arrive, but same result. By that time it was too late to RMA the boards. I then bought 2x ASRock H110 Pro (same result with no boot)
I build computers since 1993 and never had any issues with CPU’s or boards before, but this one still baffles me. I’m still not sure whether it was the boards or some incompatibility of the Intel 7th Gen, 8th Gen crap. Newegg wasn’t helpful either.
If you have a friend or some different CPU’s, test this as quickly as you can. Don’t waste your time though like me, and make sure you have some time to return them.
I did some research and back then there were a lot of people complaining about the ASUS B250 (that’s why I decided to go with the ASRock instead.
In the end I paid for 5 CPU’s and 4 boards and have 2 systems running now.

Crazy question…did you plug a HDMI plug into the HDMI port on the board itself? I’m embarrassed to admit that I didn’t realize the board itself had onboard graphics and once I did realize I had zero issues.

Yes. I have tried the onboard HDMI port, and I have installed a GTX 1660 Ti onto the motherboard with no video output.

The thing that gives me hope is that I have two motherboards and neither one will work. It seems unlikel;y that I would get two defective boards at one time.

Take them to your local repair shop, pay $25 and get the bios upsdate. Done

And you can’t hit f2 or delete and get into the bios?

No sir, i had 2 of these and you have to flash the BIOS.

Step 1. Get a USB VGA adapter and connect to your monitor. If you know how to solder and place on board great, if not go with usb option. that should solve the problem.

Step 2 download the updated bios, then try HDMI.

most of the time i get this error its solved with this easy fix.

Hope this helps

Doesn’t the USB to VGA require a driver installation in order to work?

depends on OS… but vga is old tech, so onboard graphic controller should detect it as long as boot order is delegated. remove the SSD for now. use the vga adapter or buy a old graphics card with vga press and hold f2 to get into bios.

recommend https://www.amazon.com/StarTech-com-USB-VGA-Adapter-1920x1200/dp/B005G306I2

if that doesn’t work use BelenaEtcher and use and load os like hive or simpleminer for now. boot will be only usb if there is no HDD or SSD present, it will detect usb as primary boot drive.

try that if that doesn’t work, it could be pins are bent, bad ram, cmos clearing by removing the battery.

how many beeps are you hearing when you load?

No beeps.

The only indication of the MB powering up is the CPU fan starts to run. If I have a GPU installed, the GPU fans spool up but with no video output.

No beeps, hmm that’s not a good sign at all. try my VGA work around and let me know if it works, once you get to see the bios settings your moving in the right direction. yea if CPU fan is working MB is “working” technically. By process of elimination you will find out what it going on. You can DM me, Keep me posted.

I had that problem and it was memory timing. The cpu fan would twerk, stop, twerk, stop, then spin a second and quit. If left on, this process would repeat after a while. If left on for days to weeks, you may get the video telling you to reset the bios but as soon as you power off you’re in the same boat.

I removed all but one memory stick and let the motherboard continually reboot until this error screen came up. Once that happens, you are good as long as you don’t reboot after a shutdown.

Have the windows or dos version of the upgraded bios on a thumbdrive and once you get the video install windows and the bios or just the bios from dos.

Add memory, one stick at a time once the pc boots with video. The memory could be good, like i said, the timings are not satisfying the motherboard. I fixed two gigabyte motherboards this way.

The issue is that the motherboard isnt upgraded enough to recognize the CPU, that is why the fan will go on but that is it. I already told you the only way i could fix it. Unless you have another 250 MB that you can use to flash the bios or an older cpu that is compatible, you will be taking it to a repair store.

Update: ASUS customer support stated that the two boards are dead and outside of warranty service as the two boards were zoned for Europe and not North America (where I live and where the boards were purchased) and therefore they refused to replace under warranty.

So… I am returning them to the vendor I purchased off Amazon and trying another board and vendor. Thanks for the suggestions and feedback. To date, my experience with the Crypto-specific motherboards have been unpleasant.

I would try the H110Btc or the Zotac board for mining. I’ve had excellent experiences with both! Plus the h110Btc comes with a onboard power on button built into the mobo!

Thanks. I sent back the two B250s and now have a H110 BTC board to try.