Bought a l3+ miner from cmc with a virus already on it


new to the forums, but have been watching Vosk for a few months now. Got me hooked up on buying an ASIC from (used the promo code and everything :))

Unfortunately, the “used” miner I recieved is in pretty bad shape, but I plugged it in, change the password, and set up the mining to mine to my account and sure enough everything worked smoothly until it got past 7pm my time (CEST). Then suddenly, my pool sent me a notification, that my hashrate is 0. I checked on the miner, it worked nicely… for someone else :/. Upon further investigation I found out this miner I recieved was completly rigged and had a virus on it.

I tried everything (from web update, to SSH, to SD card update) and everything is either not working or disabled. the firmware was updated to the 2019 version before I got it, soo no SSH. I tried to update via SD card (got a reader and an microSD card) and when I burn an image on it and try it with the miner, it turns on (ethernet gets lights, there is a blue light turning on inside the machine for a second or two, then the Fault light flashes and the whole machine turns off. It does that indefinetly… I figured out from an article by HiveOS, that this virus disables SD boot and changes the update.cgi, soo even if you do get it working, it doesn’t really update (web update).

I contacted CMC about this, and instead of offering some other type of help (perhaps replacement parts etc.) they just keep telling me to try things I already tried and link me software, that quite franky I have never heard of and google hasn’t either. (OkCare, an “antivirus” software). I personally only found 1 russian forum, that mentioned it, and it didn’t seem very legit.

After a few days of not responding, they reached out to me again, to tell me, that I should install Sunlogin to a PC that is connected to the miner, and their technical staff will take care of it. Firstly I am already suspicious of this, because they already sent me a miner with a virus. Secondly, SSH is disabled and the web interface clearly doesn’t work, soo what can they realisticly do ??

Does anyone else have this same problem? The virus in question is undoubtebly the one mentioned in this article: How to Save your ASICs: breaking virus update | by Hive OS | Hive OS | Medium

Any idea, how this situation can be resolved?

PS: They are responding to me, it’s not in my opinion a complete scam, but it is a bit frustrating, that I recieved not only a used miner in quite terrible condition (I knew, I was buying used, soo I was prepared for that), but secondly, that the miner was completly rigged to work for someone else.

This also makes me question their “we test every product before shipping it”, because I feel like they should see that. Perhaps they only turn it on, and check if it mines to one of their accounts and turn it off ? Idk, they were testing it for quite a while (almost a week, before I recieved a tracking code), soo I would think they would see the miner just switching accounts every day at ~ 7pm.


That sucks and can imagine how frustrating that is! Thank you for sharing this information so others can read about this. As I learn more about mining my suspicions grow as well. I’m new to the forum but hopeful this community can help all.


Hey man. I luckily havent gotten the virus yet from my L3+ purchases but I am pretty obsessive with viruses and have been trying to find out how to remove them. Have you tried this video out? He basically shorts pins to erase the virus directly from the nand memory chip.

1 Like

So glad I saw your video, we bought 45 miners 3 monts ago and still trying to fix it.
Could you confirm that we leave the wire in place after the process is complete.
If this works U’ll be shaking my tall lol.
Thank you

Is the l3+ profitable if I was to buy one what does it make a day the website to check it says only like 6$ The s9 makes more and is cheaper to buy from what I found.

Hey you remove the wire after its done clearing the nand chip. Then you just flash your desired firmware. I just got this virus on five of my miners. Glad i could help =).

Hello, thanks for following up but we still have problems,
We flashed with the SD Card with the NAND fro Bitmain 201904231534-L3 SD recover-NAND
Question: Is the Balena etcher necessary for this to work?
We did install the wire and the resistor.
When we insert the SD cards we have no lights turning on even after a few minutes to indicate that the virus has been removed.
Do we need to use the Hive or we can just let the existing Bitmain?
Any information will be appreciated,
Thank you

Is it safe to say that if you can install hiveos you’re virus free? I think I remember seeing a blue light on one of my machines. But they all have hiveos so I ignored it.

Never mind. All good.

It appears on have this virus on my L3++. I went through the instructions in the video - soldered the wire w/resistor, created the boot drive with etcher, etc. When I power the device on with the wire soldered and flash drive in, I never get a red and green light as I should. There is a red light on the board itself (not on the back with the green light) that stays lit, but that is lit from the time I power it on. Is there something I am doing wrong? I checked to make sure the solder and wires did not hit another pin and I am good there. Any help is appreciated. Thanks!

I found this video worked for me, gotta download the files in his description, did it last month.

Thanks, Jesse_G! I tried that also and it did not work. I am using a 32 GB micro SD card, is that my problem? I could not find any posts about issues with using a 32 GB card, but many of them are using 8-16 GB.