Bought a used rig....need help

I purchased a used rig off of ebay. It included everything except gpus. I received it today, hooked everything up and it it runs. The issue I’m having is when I plug my monitors, both dvi and hdmi, jn the onboard hdmi slot or any of my gpus, nothing shows up on the screen. The seller sent a usb drive instead pf the hd and he said he never had a problem booting it up. He has been very helpful on messages back and forth, qnd even offered to zoom, but before we do that, does anyone have any suggestions? Thanks


Did you plug in all of the GPUS at the same time? Sometimes that has issues on Windows systems from what I’ve read. Are you able to see the bios boot up and then nothing? Or, is the monitor not recognizing that there is anything connected at all?


The monitors don’t recognize anything. I’ve tried various combinations of connections. They don’t even show the bios when booted. I thought the jump drive would have an OS on it, but all it has is a config file.


Well, there’s a few things I can think of trying… some of which require having a separate working computer set-up, so hopefully you have another one somewhere in the house! Some of these may also require some additional hardware, depending upon what is in the rig or what you can pull from another PC.

You may have already done this one, but first off try unplugging everything from the new rig in terms of GPUs or additional peripherals. Then try to see if you can get the bios to load up from the onboard video, since the board you got apparently has one.

If you have another computer, have you tried putting any of the GPUs in there to see if they work? If they are new, it seems more likely to be an issue with the used rig. But, in theory you should be able to try testing the GPUs this way. If they are used cards, it’s possible that they have a BIOS mod which makes them only good for mining and unusable as graphics cards.

Another alternative is to pull a known working card from a different PC and try it on the board. I ended up doing this, as the mining GPUs I got wouldn’t seem to load up from the DVI connection :confused: They actually still work fine for mining, but I think they were BIOS modded to a point where they don’t work for regular graphics.

You can set-up a hard drive that you know will boot to an O/S preset-up to accept remote desktop connections. Then, plug it into the other rig and try to remote desktop in from another PC. That might let you get onto the system unless something is broken. You need a back-up hard disk for this, but you may be able to get away with making a USB boot drive.


Check for any bios display settings. Plug the hdmi cable into a gpu instead of the motherboard hdmi.


reset motherboard bios. if you planing reistall os or installed fresh not conect any gpu and in bios set use onbord video if cpu have onboard video if not use one gpu for video after done drivers plug all gpu


example on my ring if i plug any gpu no video during windows im install everything only no amd drivers after i restart plug all gpu working everything fine after start and finish install gpu drivers. ready to mining it take around 20-30min to start mine

1 Like

I’m having the same problem. All I haven’t changed is the ram. I’m trying that this weekend. New power supply, new cpu, new to me monitor and dvi cable still no video hopefully I’ll get it sorted out this weekend.

1 Like

Thank you for all of the replies. I think it’s the power supply (at this point) becuase when I have just the 24 pin plugged into the motherboard, the fan for the CPU and the GPUs all turn on, but no video, no power to my keyboard (it lights up orange when plugged into my tower). When I plug in both the 24pin and the 8pin, the power supply just clicks once, my office lights flicker, and nothing comes on. I think the 8 pin supplies power to that side of the board which contains all kf the USB ports, the onboard hdmi out, etc.

1 Like

Ok, I disconnected the Corsair 850w power supply that came with the used rig and I hooked up my Corsair 750w power supply from my tower. The rig booted up perfectly, and the video is displaying. I guess at this point I should chalk it up as a bad power supply and maybe try to seek some kind of partial refund.


Glad you got it working, there is one reason you wouldn’t get video from a card plugged into a pcie slot is in the BIOS setting for which video card to turn on 1st. The two choices are onboard and pciE. I swear I had the same problem until I switched that and I also got video from the onboard port. My mining video cards also output video if I plug into them. Anyways, you got it working so GREAT!

1 Like

ANNNDDDD…it’ still not working! So I figured out it was a bad power source. The seller went back and forth on a resolution, but I just said the heck with it and bought a new power source. The issue I’m having now is I’m trying to run the Nicehash OS from a jump drive. It loads correctly, and then asks for my login. At first I put in my user name, but that didn’t work, so I did more research and found out it was nhos with no password. So, I put that in, and then it just brings up nhos-my rig id and then $…not sure what it’s supposed to do after that. When I look at it from another computer in MY RIGS, it’s listed but says error. I can restart the rig from another computer through my Nicehash account, but obviously something is jacked up because I can’t get past the log in part

there is a universal first run login let me look it up for you brb


On system start, you are presented with a screen where you can enter access credentials to log in to the system. There is only one user configured for accessing NiceHash OS and there is no password required to log in locally.

Just enter a username: nhos and hit the Enter key (Return on some systems).

NiceHash OS is a minimal Linux operating system based on Tiny Core Linux . If you are familiar with any Linux distribution, then you will feel comfortable using NiceHash OS as well. More about command lines inside NHOS can be read here.

System configuration

NiceHash OS configuration prepared while creating NiceHash OS flash drive is located under /mnt/nhos directory in the configuration.txt file.

System logs

System startup and application logs are located under /var/log/nhos directory.

  • nhos_boot.log - contains information on NiceHash OS boot sequence
  • nhos_nhm.log - contains information on NiceHash Miner operations
  • nhos_update.log - contains information on NiceHash OS update service operations

here is the link to actual article

Thanks for the info. I’ve tried that a few times, and it takes me to a "$ symbol. Not sure what to do after that.

your going to need someone else to take over here this is where I got stuck last time I tried to use NH OS

What do you use? I’ve tried this way, and to make a bootable windows usb, and neither work.

I use HiveOS…

I used Nhos for a wile now works great but is a little tricky if you want to see what your gpus are doing can run nvidia-smi it shows you Power use temperature and which miner * if any is runing under /var/log/nhos/nhm/miners are the logs once you now the curent miner you can use tail -f to see the miners output. The overklocking is also a bit of work. Its a file in the config partition. But its all dokumented in the readme file in github.