Create a Wallet for Kadena to use for pool

I just received my first Goldshell KD-Box and I am trying to set up the pool. I was trying to create a Wallet and I tried at Hotbit, Kucoin to no avail. Hotbit does not show the wallet address its always blank but other coins do show it. Kucoin shows a message Wallet Upgrade.

Any suggestions on how to set up a Kadena wallet? Or I am open to suggestions I sure would love to go forward and mine… yea…

Thank you

1 Like

ps: Hotbit support was asking for for my UID, not sure if that should remain private?

I’ve been using Zelcore and so far happy with it. Make sure you use the k: wallet address

1 Like

Thanks for the suggestion… I was finally able to setup a Chainweaver wallet but of course this is not on an exchange. Is Chainweaver a good way to do it (not sure which chain to use) or Zelcore or exchange like Hotbit or others?

Thank you.

Chainweaver and Zelcore are loved about the same IMO.

Thanks for the information.

Does that only go for zelcore? I was wondering because my wallet address on coinmetro begins with k however when I set up my kd box …the goldshell settings won’t work unless I leave off the k: …same with the pool.

not sure, but I wouldn’t use a Kadena wallet that doesn’t support k: addresses. The whole reason they are moving to this is due to a security issue. So it works with a non k address with CoinMetro but fails if you add k:walletaddress? strange.

Yeah so I have two different k: address wallets to use …and I want to but when I set up the f2pool ( which by the way is preconfigured now in the new kd boxes ) it refused to work with a k: wallet prefix like k:somewalletnumber.001@strat…etc the shovel won’t turn green and it won’t work. I’m afraid that what I’m mining will never reach coinmetro because i set up the pool info without the k:

There is no issue to use non k: addresss if you own all chains you plan to use in general Chain 0 for mining since pools usually send money to chain 0 and I think exchanges use chain 1 like Kucoin if it will be ever working again :slight_smile:
The issue with non k: address or better said account since you can have only account with k is that if your account is non k: it will allow various public keys to own different chains under the same account. So for example you might be owner of account and chain 0 with the same name as your public key but somebody else will be able to own chain 1 under the account with same name as your public key but he will be controlling chain 1 with another public key. This was used by scammers to “steal” Chain 1 since many people had an impression that if they created account with name of their public key that they are owners of all chains.
If I am not wrong you only own chain if you send some amount of KDA to it.
What is k: account doing is that it will not allow public key that is different from account name to control some chain so it is kind of enforcing that you will be owner of all chains even you have not own/use them yet.
Not sure if it is clear what I just wrote but I think everybody mining KDA should leran about KDA blockchain since it is a multichain and very different from known blockchains.
And sorry for repeating myself again and again . . .

BTW: You can setup k: account in GS interface under username without issues. I was mining on poolflare with k: account, just make sure pool you use support k: account


I don’t have experience with Coinmetro but k: account and non k: account are two different accounts so I would say I am sure it will not reach coinmetro + I don’t have experience mining on f2Pool but you need to make sure that you also use same chain so if f2pool pays on Chain 0 as example cause I don’t know which one they use you need to make sure that exchange allows you to use same chain.
In your case you can mine to Zelcore or Chainweaver and then transfer from chain 0 to chain 1 and send to exchange from your chain 1.
Just please check your consistency on account and chain level otherwise you might waste your KDA or send it to somebody else…

1 Like

Actually what you can do is to use chainweaver and create the account without k: so name of account will be name of your public key - the one you set in your miner for f2pool. I am not sure if you have private key for your public key but if you have it you are able to validate transaction in chainveawer even if you use key not generated by chainveawer.
If you don’t have it - I am not sure if it will work but you can still create account as I wrote above but you can set additional public key - the one you own in chainweaver on the top of one provided from coinmetro and you can set account that you need only one key to validate transaction in such case you should be able to still receive money from pool to your mining account and still transfer them using public key generated in chainveawer. Let mw know if it worked and if you managed to save your mining profit :slight_smile:

Jimmyispromo has a video on how to connect a goldshell kd box to F2Pool then a wallet. Watched in the hopes to get one of them soon

Thanks your explanation was great! I just started mining today so I went ahead and switched to poolflare with my k: zelcore wallet …it set up fine. Thanks for your help !

1 Like

I’ve been mining since last evening and it looks like I have a payout of .8 Kadena however the status is UNPAID. What does that mean ?

For me it changes from unpaid to pending to confirmed over about an hour. Has it changed now?

Ah yes , it just changed to pending! Cool thanks.

1 Like