F2Pool Not Working for Anyone Else?

F2Pool is still not loading due to a connection not being secure. Anyone else running into this? How can this be fixed?

Mines good… got my payout tonight

Can you go onto the actual website though? I’d like to set up other miners at some point but I can no longer access the website as it fails to load and comes up with the message “This site cannot provide a secure connection”. It happens both on Google Chrome and Microsoft Edge.

Sorry no my bad I just check the app

So I was able to get onto F2Pool on the website since I had to download a google extension (ultrasurfing) to go behind the scenes. Now I’m able to get onto the website (the app is still saying server error). Only thing now is that it’s saying my miners are offline (?)

My F2pool is working fine. Did you try deleting the app and reinstalling?

Hi Michelle
I have been offline on F2Pool for 2 weeks now I can login into my account see my mined coins there but can not withdraw them or put my miners back on the F2pool I don’t get any error messages.Been touch with F2 support they reply every couple of days saying do this do that done everything all the tests Ping still no change now they are on holiday for 10 days Chinese new year but I am still mining on DXPool, are you still mining?

Mine’s not working. Wouldn’t connect to the pool, had to connect to a different pool. Connected to Poolin. The server can’t establish a secure connection or something.

I’ve had no issues with f2pool and I check every 2-3 days