KDBox | Miner pool is not ready yet

Hi folks,
Need your expertise. So, I’m running into the same issue that I’m noticing many people are encountering. Recently, I set up my lovely KDBox only encounter the message on the Goldshell Dashboard “Opps, Miner pool is not ready yet.”
The following was done and I’m still getting the same message:
1- Disabled all antivirus software and still no connection to the f2pool.
2 - Unlocked updated all pools

3 - Have not changed the firmware because it seems like I have the latest version 2.1.1:

4- Changed from WIFI to wired
5 - Periodically reset to default with many restarts and still no go
6- Checked my router and noticed no issues

Any ideas to help out would be greatly appreciated.

Hi Sasealy
The latest firmware is 2.2.1 cpb. Power your miner then reset to factory by pressing and holding the inset reset button with pen tip under the Blue&Red light hold until lights go off then on again. Go to www.find.goldshell.com to find your miner click on hex nut icon that will open Goldshell Interface Dashboard unlock your miner
PW123456789.Download latest firmware from https://github.com/goldshellminer you need to download 2.2.1 cpb which is for all Goldshell miners .Once unlocked go to System click on paper clip Icon update to new firmware from you download takes 2 minutes once updated go find.goldshell.com again you will have a new IP for your miner click on the hex nut take you to Dashboard Unlock again go to Miner then pool settings and load your pool settings.
I suggest that you use DXPool its more reliable you are going get problems with F2Pool DXPool is very easy you have all the info just with click .
How To Put Kadena ($KDA) miners onto F2Pool - KD Box, Is It Worth It? - YouTube

HI SindhisKing,
Thanks for responding. The firmware has been updated however, I’m still getting the same message.
I added both pools to test it out and still, it did not work.
Also, I did another factory reset with the same result.
What I did notice is that my IP did not change after the firmware upgrade.
Any thoughts?

Hi Sasealy
Is this the first time you setting these KD Boxes up or were they working before.
Try using only DxPool I have noticed from your pics above that you are using your wallet address in the mining setting its only done with F2Pool that way.For DXPool you got to use your account settings and miner name example say your account with DXPool is SSandor this is your user name and your miner name is S123 in the DXPool settings you would put like this SSandor.S123@stratum+tcp://ltc.ss.dxpool.com:6611 and not your wallet address wallet address only for F2Pool. Here is example how mine is setup

When you do this unlock your miner first and change password of your choice that should work.
Do the whole procedure from hard reset to the end let me know how you get on Thanks.

1 Like

Hey SinghisKing,

I forgot to mention that I did change it over to DXpool:

I’m not sure if the user naming convention I created(worker name too short?) is correct but, seems similar to your suggestion.
I’ll try it again from the hard reset as you mentioned and keep you posted. Thanks

Hi SinghisKing,

I tried the sequence over again with your suggestions and it still did not work:

Just to clarify, the correct firmware name in question is firmware-Goldshell-KDBox-2.2.1.cpb correct? That is the only one that made sense that was labeled for low fan speed. There’s another one for high fan speed firmware-Goldshell-KDBox-2.0.7q.cpb that I’m not really interested in since it’s loud however if it gets the box running, I don’t have much of a choice. Anyhow, let me know what you think.
Anyone else has some thoughts/ideas, please don’t be shy and share them with us.

Thats the one Sasealy use 2.2.1 cpb that also lets you control your miner remotely can you please send me full page screenshots of Goldshell Dashboard in all three modes Home/Miner/System .Also how are you resetting your miner which button are you using?Send this info ASAP Thank you.

Certainly, see below:

Ok yes and 2.2.1.cpb is the one I used.
I reset the miner as you mentioned by pressing/holding the tiny black button(under blue/red lights) until the blue/red lights up, then shuts off and I released the button.
Also the blue light is consistently flashing blue, is that normal? Thanks.

Blue flashing light means it is hashing @Sasealy

Hi Sasealy
The button you are pressing to reset miner is it the black button sticking out back of the miner? Here is my whatsapp number +447787343139 video call me 9 am US time tomorrow I will guide you and we get it done Thank you


Hello ,
KD-BOX miner can work with wifi and ethernet both of them , if you have problem in connecting to pool , i suggest you to use poolflare.net for connecting , i suggest to my all customers to connect to this pool because of its good and stable connection .

If blue light is blinking , it means miner is connected and if connected , in the pool configuration you must see green circle on the left side of address .

if need any more help let me know @Sasealy

Folks, SinghisKing suits his name. He volunteered his time to help and we found out the issue. My router was on the wrong network and GoldShell products need to be on 192.168.0.XXX. At first, we figured/convinced the router IP was set by default to be fixed but, I simply changed the IP and I’m up online!!
Thanks to SinghisKing who supported me through this initial part of my journey. He is definitely a solid, genuine person who’s support and kindness is rare.
Thanks again SingisKing!


Hello B11, Thanks for the extra tip and support!

You are Welcome Sandon and Thank you for your kind words really appreciate.I am always here to help out that’s what I have learnt in life that “If You Work Together You Can Achieve A Lot” Thank you.


Really nice of you to help someone else like that with your personal time. That is a good @VoskCoin community spirit. :+1::+1::+1:


Thank you JoeJoe lets all make VoskCoin a truly high spirited Community together really appreciate

1 Like