Mobo won’t run when ATXPWR2 connected to PSU

Hey All,

When I connect the PSU peripheral connector to the motherboard ATXPWR2 the motherboard stops running. If I remove the connector from the ATXPWR2 the motherboard runs.
I need some trouble shooting advice/recommendations?
PSU Thermaltake 1200 Gold 80
Mobo Biostar TB250-BTC

Are you using the dual 4-pin connector that is hardwired to the PSU or are you using a cable plugged into a modular peripheral port?

1 Like

Hey bick0012, I’ve tried the direct hardwire 8-pin and a 4-pin to peripheral connector port.

I don’t have an SSD or USB stick in. But that should matter- correct?

You should be able to get into the BIOS without an SSD. The hardwired cable marked CPU that can split into two 4-pins is the one to use. If that doesn’t work, it could be a bad power supply or another cable causing the issue. If you used any adapters or non-Thermaltake cables elsewhere, that could be the problem too. You should also power the two molex connectors on the board but that shouldn’t matter for this issue.

The mobo will run with the 24-pin but as soon as I add the 8-pin or 4+4 pin to the ATXPWR2 the mobo runs for about 2 seconds then quits.

I believe this has to be a mobo issue as once the ATXPWR2 has power, with or without AUXPWR or SATAPWR, the unit shuts down after a few seconds.

It certainly could be the board. My TB250 did the same thing when I used a non-EVGA cable with an EVGA PSU to power the two molex. It would start for a couple seconds and shut down. Hopefully you have access to another board or PSU to test them out.

1 Like

I am having a very similar issue did you ever get this solved?