Problem Adding 4th GPU - Fixes?

Had my rig up and running just fine with 2 GPUs. Added a 3rd and saw no issues. Once I added the 4th, the mining program runs for a few minutes then quits unexpectedly. All drivers are up to date and mobo is showing no errors when I boot up. Issue only occurs once I’ve been mining for a few minutes.

  • Currently using nanominer
  • All GPUs are Geforce GTX 1660s
  • Mobo is ASUS B250 Mining Expert

Tried to add the autoUpdate=true in nanominer config file in case there were any updates needed. Seeing no change in the issue.

Wondering if I need to adjust settings in the asus bios? I’ve reset to default with no luck then tried setting the PCIE settings to Gen1. Same issue occurs.

I’ll keep mining with the 3 GPUs for the time being and continue to troubleshoot. My thoughts are something is needed in the nanominer config files but I haven’t found a solution yet. Any suggestions are appreciated!

bios shut be gen2 all pcie, onboard video if have igpu shut be off if you use windows increassing virtual mem to 32000

1 Like

Try the 4th GPU by itself to see if it or the riser is the problem.
I had similar problem adding 4th GPU, it stepped on my USB mouse driver address so I used a different port for the mouse.
Not all same brand, same model GPU’s are equal. Sometimes, big difference

Thanks gents. The riser itself was good.

And I ended up changing bios settings to Gen2 and increased the custom virtual memory and everything appears to be working okay.

Keeping an eye on it in case anything else pops up but so far so good.

1 Like

good. any more questions just ask

Great, Nice Job

1 Like