Problem adding more than 4 Nvidia GPUs - "BlinitializeLibrary failed 0xc00000bb"

Problem: Adding 5th Nvidia 2060 Super GPU causes failure to boot with error “BlinitializeLibrary failed 0xc00000bb” displayed on black screen.

Rig works fine with 4 Nvidia 2060 Super GPUs with attached risers, and the 5th GPU and riser work when used in place of one of the original 4 (so the problem not with the GPU, Riser, or cables.)

OS: Windows 10 professional 64
GPUs: Nvidia 2060 Super with latest Nvidia Studio driver(s) Ver 452.06, release date Aug 18, 2020
Asus mother board:  Prime Z390-A
Bios Version:  1502 x64
Build Date and time: 02/21/2020

ME FW Version:

Bios settings:
Above 4G Decoding "Enabled"

I have set all the following to "Gen2", Also tried all the following set to "Auto" and "Gen1"
DMI Max Link Speed
PCIEX16_1 Link Speed
PCIEX16_2 Link Speed
PCIe Speed

Additional settings:
HD Audio Controller “Disabled”
Serial Port 1 “Disabled”

Please advise or point me in a direction for potential next steps to get motherboard to boot with 5th GPU. Any help greatly appreciated!

Do you have legacy mode enabled for USB? It may need it.
Which graphics are set to initialize first, PEG or internal, try both.
Try reseating the riser card in the pcie slots or use different slots.

Sorry but that’s all I know of right now. but wondering about the A in the z390-a motherboard. Bitwit. buildzoid, or Steve from Gamers Nexus mentioned something particular about the A series motherboard

I think your second question about graphics initialization was the core of the issue. I updated the BIOS. Then the ONLY change I made to BIOS settings was to enable above 4G (which was enabled on the previous version). I then added the 5th GPU to a different slot and problem solved! I then added my 6th GPU with no problem.
Thank you for your input Dollyshunk, much appreciated! My next task is to learn about undervolting and overclocking. I’m sure there is some helpful stuff here at VoskCoin.

1 Like

That’s Great! Happy Mining