RX580 4G reported hashrate vs pool hashrate BIG difference, cause?

my miner rig 6 x RX580 4G stopped working with Claymore miner on Windows10 with ETH mining so I thought I should switch to mining ETC based on profitability.
I checked for other miners and now trying to use teamredminer to mine ETC.

Now the problem I can’t figure out, why my cards report total hashrate of 155 MH/s and pool reports like 2 MH/s ?

Miner is on 4G+ sim card internet, windows10, ping to EU1-etc.ethermine.org pool is 15-25ms.
No invalid shares.
No errors on hwinfo or anything strange that I have noticed.

Tried using different pools, looks like the same, maybe I am missing something?

mining eth etc you need use claymore or phoenix redteamminer is for rvn coin

You can use teamredminer for Ethash (ETH, ETC, Etc…), it just is not as good as Claymore or Phoenix

1 Like

reason because is for rvn

What version of teamredminer are you currently running? What does your teamredminer config look like?

Also, if you have the latest version of teamredminer, try considering the options for the dag, since you said you are using 4G versions of the RX580.

  --eth_alloc_epoch=N   Allocates enough memory for the given epoch from the start.  The miner will try to allocate more
                          if it needs to later during mining.  It"s recommended for rigs with one or more 4GB cards to test
                          and set this to the max possible value to avoid reallocations at epoch switches.  Optimal Linux
                          rigs should be able to handle epoch 380, Windows rigs a little less (373-374).
  --eth_4g_alloc_adjust=X,Y,...  On Windows, the allocation balance is very delicate for 4GB gpus being able to reach their
                          maximum possible DAG epoch.  The miner uses a strategy that has worked fine for our test gpus,
                          but other setups can benefit from tweaking this number.  The valid range is [-128,+128].  Zero means
                          no adjustment.  You provide either a single value that is used for all 4GB gpus in the rig, or a
                          comma-separated list with values for all gpus, including non-4GB Polaris gpus.  Values for non-4GB
                          gpus are ignored.

This was taken from the Ethash portion of the config options. I would also check their discord:

Using latest teamredminer version, tried different miners, different coins, weird results for some reason.

As I was getting weird megahashes I tried https://minerstat.com OS ubuntu based, nice UI got back my megahashes I was used to, and mining ETH on ubuntu with 4G card still works, so happy for now :slight_smile:

minerstat is a best mining os