"Click" sound on mobo, now won't power on...is it dead?

I have an ASRock H110 Pro BTC+ mobo and it was working. Then I turned it off and went to install HiveOS. When I turned the mobo on, I heard a “click” sound and it didn’t power on. Now it won’t power on at all. I tried a new PSU as well. Anyone ever have this happen to them or know what it could be?

I’m desperate so any help you guys can give would be so amazing. Thanks guys.

Did you try looking closely at the diodes and see if any of them look burnt?

1 Like

Hey man. Yeah I don’t see or smell anything that would indicate it got fried. I must be doing something completely noob.

I first had the mobo powered by using the 24-pin atx cable to the mobo, and the 8-pin plug labeled “CPU” to the port labeled “ATX 12V” next to the cpu.

That was making the fan spin and all so I didn’t plug in the 4-pin molex cables. I’m wondering if that is why it’s not working but then how would it explain why it was working before, without the molex cables.

This is what ports I have on the psu

I have two of these PSUs.

The PSUs came with some cables as well. Should I plug in this cable…

to one of the 6-pin ports on the PSU (labeled “Peripheral and SATA”)? That doesn’t seem right as it’s not a peripheral or SATA.

It sounds like it hooked up right… does the psu smell like burnt wiring? When you have the psu plugged in to the wall and the motherboard, are there any leds on the board that should light up?

No I don’t smell anything burnt on the PSU or the mobo. I don’t need to hook up the molex cables to make the mobo turn on, right? I mean, it was on before without them.

No, to turn it on and post, all you need is 24pin main and cpu power.

Should I try it anyway? If so, can I plug into the 6 pin port on the PSU? The only cables with molex that came with this PSU are ones with a 6-pin connector on one side. So I guess I don’t really have a choice???

Oh okay. Nevermind for that then

Oh shit!!! I think I might’ve just fucked this mobo up…I had one of the risers plugged into the SATA_POW1 port on the mobo. It was the 6-pin to (4) SATA looking connections…it was plugged up to an empty riser…that must’ve been when I heard the “click” and nothing worked every since…shit I guess that must’ve did it, right?

that was the cable i had plugged into the SATA_POW1 port on the mobo and it was connected to an empty riser. Did I kill it with that move?

Well I tested the PSU and it is fine. I listened closer and now I can hear a clicking sound that is repeating about every 1 second. Very faint noise that can barely be heard. tick…tick…tick…tick. Doesn’t matter if I press the power button on the mobo or not. the only way it stops is if I turn the PSU off. So freaking strange.

It’s just hilarious because now that mobo costs lik $500 on eBay…I paid $180 just a couple of weeks ago!!! LMAO what a great day! hahahaha

Yeah, you shot power somewhere that it shouldn’t have gone… so the clicking you hear may just be the fan, but the only sure way to find out is to take the psu cover off and look at resistors. But for the motherboard… it’s probably a paperweight now. Check into the Biostar TB250 BTC motherboard… those are less expensive I believe.

Yeah I’m starting to agree with you lol. But I looked again at the sata cables and everything that I can find online suggests that there is nothing wrong with doing that. Just that the risers may not be able to handle that much wattage and the cable could melt. In my case there wasn’t even a gpu connected to it so I can’t imagine it was pulling in substantial wattage.

As for the psu I found a method on corsair’s website to test it. Shorting pins 4 and 5 and if the fan starts up, it’s good. The fan started up so it looks like the psus are fine.

Really weird. But hey, at least I have a sense of adventure! What a ride! lol thanks man for trying to help me

1 Like

Be sure to get the TB250 BTC-PRO version with the 12 riser pcie connectors … $159 from China, $400 from USA on eBay.

Where do you order from China? Like alibaba or something?

Clear the CMOS on the motherboard and make sure the 4+4 CPU cable is plugged into the CPU 12 Volt Aux connector, not the 6+2 Pcie connector. The Pcie connector has different shaped pins so shouldn’t be able to plug in, yet with enough force I guess it might fit in there.

I did clear the CMOS…well at least I performed the steps to do it, but no dice. Same outcome.

The PSU has two dedicated cables that are integrated into the psu. One is the 24 pin and the other is an 8 pin labeled “CPU”

It was working earlier today. So I guess those connections should be working.

And it’s making that “clicking” sound if I listen very closely. It will eventually stop, but if I wait long enough and turn the psu on again, it will start back. It seems like there is some kind of circuit protection happening or something…at least that is what my intuition is telling me. But then again, look where my fucking intuition got me HAHAHAHA


Newegg orders from China but it could be months before you get the motherboard. That’s why is bought mine from ebay.

I bought my first biostar pro motherboard from newegg, it came from Israel. It came in an ASUS box, wasn’t the PRO version …was the tb250 BTC+ with only 6 pcie slots, and wouldn’t run more than 3 risers. Newegg did RMA the board and the one I got on eBay shipped from USA. Got it quick and it worked great.

I ordered HDD SAS cables from Newegg, they used a 3rd party seller and the order took 3 months and several complaints but I did finally get them. I re-ordered some off Amazon and got them in two days and were a better product.