Mini DOGE stopped working. Help!

At this point things are over my head. Hopefully someone here has an idea of how to hack into the system and change the firmware back.

I wonder if there are any hidden or combinations of buttons on the unit to force boot sequence to bypass system errors and continue on? Like safe boot in Windows. Once we get into the O/S side of things I stumble more than normal. (I am assuming here that the boot failure is caused by not finding a wifi device.)

Sorry, I just am trying to make sure I am understanding correctly…did you plug the ethernet cable directly into the miner from your laptop?

Yes, I bought a USB to ethernet adapter as my laptop only has wifi. I plugged the adapter into my laptop and the ethernet cable was between the laptop and miner. I was hoping to get access to the program.

Once plugged in, can you go to search bar on your browser and try 192.168.0.1 or did that not work?

You may have to turn wifi off on your laptop for it to pi k up ethetnet cable

No connection between my laptop and miner with wifi off. I hooked everything back up like it would normally run. I logged into my 192.168.0.1 and monitored the ports when I plugged in the miner. It briefly flashed on the screen that 11 packets were sent and zero were returned. Would this be an indicator that the network card is bad? I saw a video that said Goldshell has been having problems with them on the mini Doge. The vid was from “The Anomaly” channel on YT.

try resetting your miner, then unplug it. Plug it back in and within 20 seconds, enter the ip of the miner on the browser, then quickly connect it to wifi, then connect to ethernet if you want to connect via ethernet and then disable wifi to get it to only connect via ethernet…then add the miner pool settings and save, then change the goldshell password etc.

I would open a ticket with tech support, I’m not sure what else to suggest. Keep us posted on the fix. If I come across anything else to try I’ll let you know.

Hey @Ghost_Rider_USA , I’m just checking to see if you have any updates. I am curious what the issue is. Let us know once you have some more info or feedback from Goldshell.

I had the same problem with one of mine and it is dead. I submitted a support ticket to Gold shell and got nothing back in return. At this point if there was a way to reflash the SD card or whatever I would try it because gold shell is absolutely no help on this break down issue.
I can’t wait until there is a Stateside Hardware support company for these things (if ever), so I can get a new controller or whatever it is that is causing it to stop working while it is still profitable. I’ll let you know if they get back to me eventually. I’ve submitted twice with my order number to no avail. :man_shrugging:t2: - :clock3:

There is a way to reflash the miner with an sd card to update the firmware.

I have not had to do this, but I have seen several posts about it, check it out, it may solve your issue.

Thank you!

Goldshell got back to me within a day or 2 of starting a support ticket.

The second email had files for a SD card.

John (goldshellminer)

Nov 28, 2021, 10:58 GMT+8

Dear customer,
Please try to flash the miner by microSD card to see if it works.
There are 4 files attached to this email. The 2 compressed packets [ IBSMK Setup 1.8.5 & Please unzip this file….] are the files you need to flash the miner by SD card. The video and document will show how you can do this.
Excuse me, is there a frequent disconnection problem with your device?
I hope it can solve your problem.
Kind regards.
John

Attachment(s)
Burn video.rar
IBSMK Setup 1.8.5.rar
Install the firmware by SD card-已转档.pdf
Please unzip this file-MiniDOGE-2.1.1(1).tgz

I have not got this to work yet. The IBSMK file unzipped and opened. I had to look for an App for Windows 10 that would unzip the (.TGZ) file. The 256mb file connects to their screen but did not load on the SD card when I hit the blue button. I tried 2 cards. It also does not load into my miner when I saved the file to a card myself.

I have a similar problem and have been working with Goldshell. They too sent me the 4 files like these. I installed their IBSMK SD card writer software but like you it wouldn’t burn the image properly - and failed.

I realized this was just a Chinese version of Etcher. So I went to Etcher’s website and downloaded the US version. In Etcher I picked the firmware file they sent me and it flashed to the SD card just fine. The rest of their instructions worked fine to upload the firmware.
*Note - make sure you don’t power down the miner once the flash is done. Just eject the SD card as they say in the instructions. The miner will then reboot itself.

2 Likes

The good news is that Etcher worked! The bad is that it went offline after 20 minutes.

1 Like

At least it worked for a few minutes. Maybe with that info tech support will have another idea…possibly hardware? Also, once you got it working, did you update your mining pool info? There were big changes this weekend that booted tons of people off of pools. Their url’s and stratums changed. I use dxpool, and it changed from .com to .net for the url, the other thing I had to change was the stratum address. Just a shot in the dark, but maybe check your pool address and stratum to make sure it is the updated one.

Goldshell showed me a cool trick. If you put debug at the end of your miner’s url you can view 10 tabs of logs and information on chip temps, memory usage, startup scripts, logs, and hw errors. They asked that I export them, zip them up, and email them in.

On a side note: my miner just started working when I tried plugging it back in today. Was down 10 days. I had already updated to the .net pools so that wasn’t it. Honestly I don’t know what changed - and I hate that. But I’m happy it is working and I’m not going to touch it unless I have to.

Add debug, like this:
http://192.168.86.61/#/debug

2 Likes

I had to add the pool info again. I let it auto fill the address. How would I check the stratums?
Thanks

I’ll check that out JoeJoe. I really appreciate your help and from the others.

If I hit the autofill button for dxpool it will put in a .com stratum. I just changed the .com to .net. I think there is a video floating around, I’ll try yo find it