New Goldshell KD Box - Not hashing

I just received two Goldshell KD Boxes. One is working just fine but the second one is not hashing. You can see the power is working, but it’s only cold air blowing out of the box. I am using dxpool.

Firmware version 2.1.1
Hardware version 40.40.HA

Any suggestions are greatly appreciated.
Thank you.

You’re KD BOX is defective. Get in touch with the support and you’ll need to send your miner to hong kong to have it serviced. is your power green or red?

The power shows green.

Is your kd box wifi? Try updating your firmware and see if that will help.

It’s connected with the Ethernet cable, but the box does support wifi. Dxpool sees the box in the pool, but it’s not hashing and the air coming out of the box is cold. I also setup a second box and that one is working fine.


Try plugging in with a different psu, and try hashing at a different pool. I’m giving you all options that were given to me from goldshell. If all else fails, you would need to get it serviced.

Yep, tried the different pools, but no go. I can try a different PSU and upgrade the firmware.

Are both KD boxes Wi-Fi? Or just the one your having issues with?

Both support wifi and they are both set up and connected with Ethernet cable.

I agree with cryptominernv than,

So assuming that the KD box is correctly set up for Ethernet connection (WI-FI is off in settings),

Next step is to try mining from a different pool. Only do this with the one having issues. If it starts to hash at a different pool, than you have something not set up correct at Dxpool. If it still does not hash at another pool, than its most likely the KD box itself…

I also tried Poolflare with the same results. It seems the KD Box itself is not working. The air coming out of the fans is cold, not warm.

Here is a screenshot and a picture of the back of the miner:


Shucks, Looks like you should contact Goldshell or the seller you bought it from. Going to have to take the warranty route now…

When you move the box around, does anything rattle around? Is there any visual defect you can see when looking inside it?

One last thing, try updating to the newest firmware version. 2.1.3 May be worth a try…

Yep, I updated to the latest firmware 2.1.3 but same problem. It does not seem anything it loose.

I contacted the seller and waiting for an answer.


1 Like

Keep us updated

There is nothing the seller could do to help you out. If you bought this and if the miner is under warranty, you can contact goldshell support and ask them to send you a repair form. You may have to explain to them about all the steps you taken to get to this point. They will check your serial # and QR code and determine whether your miners are to be fixed without repair fee. What sucks about this is that you would have to ship the miner to hong kong. I did this with one of my ck box, and the shipping cost was over $100…

Not necessarily true, there are awesome sellers out there that provide help in these situations.

It depends on who you purchased from. But this thread is not about sellers… so back to the topic :slightly_smiling_face:

1 Like

Looking at the pictures you provided, I would suggest one power rail per box. Also, are you sure your KDBOX doesn’t have Wifi? From your picture, it looks to have WLAN. Might be worth trying to see if that is disabled.

You mining both on the same pool?

Yes, both miners are in the same pool. None of the miners are on Wi-Fi, they are both connected to the Ethernet Cable. I also placed the miner that is not hashing on its own separate power supply on a different outlet, but the miner refuses to hash…

I bought one of the miners from ASIC Marketplace and another from Miner Bros. They are supposed to be new miners, not used.

I have emails to the distributor/seller and Godlshell, waiting for a reply.

1 Like