RX5700XT rig not working, GPU not recognized

So, I assembled all my rig parts today, powered up successfully, I installed hiveos on SSD and it boots fine, installed the latest drivers for RX5700XT however, them won’t work, it shows as it has 0 GPU while there is 6 connected.


1 Like

You connected six GPU at once? If so, that’s likely your issue. Get it running with one, then add the others.

So, I remove all the other ones and leave only 16x PCI?
Install driver for this, then I can connect the others as well?

From what I’ve read here, and elsewhere, some systems won’t boot initially with multiple GPUs hooked up. Hook up one GPU on the MOBO, get everything running properly, and then add the others to the risers. It needs to recognize one, before it can recognize the rest.

1 Like

The thing is it doesn’t even recognize one
I tried right now, removed everything, rebooted, left only 1GPU on 16pci, reinstalled drivers, still no gpu found

Are you putting the GPU on a riser, or directly on the mother board?

I’m using a Riser, shall I put one directly?
But then I’ll be able to switch to raiser, or I’m forced to leave this one there?

Put it directly, and see if that works first. Then, you can try moving it to a riser. Having to leave one on the MOBO won’t be the end of the world if it gets it to work. :wink:

Putted directly into the MOBO, still not found

Bad board? Bad Power supply? Bad card? Check your wiring. Other than that, you’ll have to wait for a Member who’s more experienced to answer up.

I don’t think is a problem with hardware or anything, as everything is brand new, except for the GPUs but them have passed a tech quality check and are good as new…
So I have no idea really

1 Like

I think is just much better to go back to windows and that’s it.
hiveos, too complicated

1 Like

Yo I’m so frustrated.
Apparently they sold me broken GPUs cause them either doesn’t work on Windows.

You can try changing the PCIe slots in the BIOS to Gen 1. It is worth a try unless you are sure the GPUs are bad. Try changing the primary graphics to PCIE and hook the monitor to one card.

1 Like

I’m utterly stupid.
I’ve connected all the cables, except the 6pin for alimentation :expressionless:
Them works fine now

Yep, that will do it. I had that issue one time. was getting ticked off cause it WAS working earlier. forgot to plug riser to PCI-E. Doh!

1 Like

Yeah, happens a lot when your brain is fried upon work and other stuffs :sweat_smile:

So, now them are recognized etc.
However, miner still won’t work, giving this:


Whatever miner I try, they all crash/stop.

GPU’s are recognized tho, so no idea.

Any help?

Which AMD drivers are you running?

i think the latest, 19.50